To navigate through "An Adventure at the Museum" you need to have Adobe Flash Player installed. To get the latest version,click here.